KBEA-00003 - Accelerator Supported Platforms

ElectricAccelerator Supported Platforms

This page contains information on the platforms supported by ElectricAccelerator (“Accelerator”). For more information, see the “Supported Platforms and System Requirements” chapter in the ElectricAccelerator Installation and Configuration Guide at http://docs.electric-cloud.com/accelerator_doc/AcceleratorIndex.html.

Note that Electric Cloud no longer provides technical support for some Accelerator versions listed below.

Platform Support Limitations

Accelerator platform limitations are described here. If this document does not contain your version, see the “Supported Platforms and System Requirements” chapter in the ElectricAccelerator Installation and Configuration Guide for your version at http://docs.electric-cloud.com/accelerator_doc/AcceleratorIndex.html.

Operating Systems

Additional Support Information

Operating System Support

Linux

Debian Linux Version  
    Accelerator Version   
10.0 9.1 9.0 8.2 8.1 8.0 7.2  7.1   7.0   6.2 
Debian 8
    kernel 3.16 series (64-bit)
x x x              
Debian 7
    kernel 3.2 series (64-bit)
x x x              
Red Hat Enterprise Linux Version  
    Accelerator Version   
10.0 9.1 9.0 8.2 8.1 8.0 7.2  7.1   7.0   6.2 
RHEL 7.4 (kernel 3.10.0-693, 64-bit) x                  
RHEL 7.3 (kernel 3.10.0-514, 64-bit) x x                
RHEL 7.2 
    kernel 3.10.0-327 (64-bit)
x x x x            
RHEL 7.1
    kernel 3.10.0-229 (64-bit)
x x x x          
RHEL 7.0
    kernel 3.10.0-123 (64-bit)
x x x x x        

RHEL 6.9
    kernel 2.6.32-696
    (64-bit for Cluster Manager;
    32- and 64-bit for eMake and agents)

x x                
RHEL 6.8
    kernel 2.6.32-642 (32- and 64-bit)
x x x              
RHEL 6.7
    kernel 2.6.32-573 (32- and 64-bit)
x x x            
RHEL 6.6
    kernel 2.6.32-504 (32- and 64-bit)
x x x x x        
 RHEL 6.5
    kernel 2.6.32.431 (32- and 64-bit)
x x x x x x      
RHEL 6.4
    kernel 2.6.32.358 (32- and 64-bit)
x x x x x x x x x x
RHEL 6.3
    kernel 2.6.32.279 (32- and 64-bit)
x x x x x x x x x1
RHEL 6.2
    kernel 2.6.32.220 (32- and 64-bit)
x x x x x x x x x
RHEL 6.1
    kernel 2.6.32.131 (32- and 64-bit)
x x x x x x x x x
RHEL 6.0 
    kernel 2.6.32.71 (32- and 64-bit)
x x x x x x x x x
RHEL 5.11
      kernel 2.6.18.398 (32- and 64-bit)
x x x  x             
RHEL 5.4+
    kernel 2.6.18-x (32- and 64-bit)
x x x x x x x x x
RHEL 4.8+
    kernel 2.6.9-x (32- and 64-bit)
    x x x x x x x
SUSE Linux Enterprise Server Version  
    Accelerator Version   
10.0 9.1 9.0 8.2 8.1  8.0 7.2  7.1   7.0   6.2 
SLES 12
    kernel 3.12.28 (64-bit) 
x x x x  x          
SLES 11 SP2 
    kernel 3.0.10 (32- and 64-bit)
x x x x  x x x x x x
SLES 11 SP1
    kernel 2.6.32 (32- and 64-bit)
x x x x  x x x x x x
SLES 11
    kernel 2.6.27 (32- and 64-bit)
x x x x x x x x x
SLES 10 SP4
    kernel 2.6.16
      x  x x x x x
Ubuntu Linux Version   
    Accelerator Version   
10.0 9.1 9.0 8.2 8.1  8.0 7.2  7.1   7.0   6.2 
Ubuntu 17.10
    kernel 4.13 (64-bit) 
x                  
Ubuntu 17.04
    kernel 4.10 (64-bit) 
x                  
Ubuntu 16.10
    kernel 4.8 (64-bit) 
x                  
Ubuntu 16.04
    kernel 4.4 (64-bit) 
x x x x            
Ubuntu 15.10
    kernel 4.2 (64-bit) 
x x x  x            
Ubuntu 15.04
    kernel 3.19 (64-bit) 
x x x  x          
Ubuntu 14.10
    kernel 3.16 (64-bit) 
x x x x  x          
Ubuntu 14.04
    kernel 3.13 (32- and 64-bit)
x x x x          
Ubuntu 13.10
    kernel 3.11 (32- and 64-bit)
      x  x x        
Ubuntu 13.04
    kernel 3.8 (32- and 64-bit)
      x  x x x      
Ubuntu 12.10
    kernel 3.5  (32- and 64-bit)
      x  x x x x3 x x1
Ubuntu 12.04
    kernel 3.2 (32- and 64-bit)
      x x x x x x
Ubuntu 11.10
    kernel 3.04 (32- and 64-bit)
      x x x x x x
Ubuntu 11.04
    kernel 2.6.38 (32- and 64-bit)
      x x x x x x

1 RHEL 6.3 and Ubuntu 12.10 are supported as of Accelerator v6.2.1.

2 RHEL 6.1, RHEL 6.2, and SLES 10 SP4 are supported as of Accelerator v6.0.2.

3 Ubuntu 12.10 support is for eMake and the Cluster Manager only, no agent support.

Notes:

Ubuntu 9.10 support ended as of Accelerator v7.1.

For Linux 32-bit, only x86 is supported. For Linux 64-bit, only x86-64 is supported. IA-64 (Itanium) is not supported.

Solaris

Solaris Version     Accelerator Version   
10.0 9.1 9.0 8.2 8.1 8.0 7.2  7.1  7.0   6.2 
Solaris 10 SPARC  x1 x1 x1 x1  x1  x1  x1 x1 x x
Solaris 10 x86 x1 x1 x1 x1  x1 x1 x1 x1 x x
Solaris 9 SPARC                 x3 x2

1 Solaris 10 support for the Cluster Manager ended as of Accelerator v7.1.

2 Solaris 9 support for the Cluster Manager ended as of Accelerator v6.1.

3 Solaris 9 support ended as of Accelerator v7.1.

Note: For Solaris, Cluster Manager and eMake are 32-bit; agents are 64-bit.

Windows

Windows Version    Accelerator Version    
10.0 9.1 9.0 8.2 8.1  8.0 7.2  7.1  7.0   6.2 
Windows 10 (64-bit) x x x x            
Windows 8 (64-bit) x x x x  x    x  x  x  
Windows 7 (32- or (64-bit) x x x x  x x x x x
Windows Server 2016 (64-bit) x x                
Windows Server 2012 (64-bit) x x x x x        
Windows Server 2008 R2 (64-bit) x x x x  x x x x x
Windows Vista (32- or 64-bit)                 x x
Windows Server 2003 R2 (32-bit)       x x x* x x
Windows XP SP3 (32-bit)       x  x x x x x

* Windows Server 2003 R2 64-bit support ended as of Accelerator v7.1.

Notes:

Windows Vista supported ended as of Accelerator v7.1.

For Windows 32-bit, only x86 is supported. For Windows 64-bit, only x86-64 is supported. IA-64 (Itanium) is not supported.

Make Versions

Versions of Make Operating Systems
GNU Make Linux, Windows, Solaris 
Microsoft NMAKE Windows
Symbian Windows
Rational clearmake (GNU compatibility mode) *  Linux, Windows, Solaris
Visual Studio Windows

* Limited support

Emulation Versions of eMake

GNU Make  NMAKE Visual Studio  clearmake 
4.2, 4.1, 4.0, 3.82, 3.81, 3.80, and 3.79.1 8.x, 7.x 2015, 2013, 2012, 2010, 2008, and 2005   Yes

Notes:

Visual Studio 6 can build workspaces by exporting them to NMAKE files. This must be done each time something changes in the workspace.

Support of GNU Make 4.2, 4.1, 4.0, 3.82, and 3.81 is partial only. For details, see the “Supported Platforms and System Requirements” chapter in the ElectricAccelerator Installation and Configuration Guide for your version at http://docs.electric-cloud.com/accelerator_doc/AcceleratorIndex.html.

ClearCase

 ClearCase Version 
7.1.1, 7.1.2, and 8.0* 

* Because of a ClearCase issue, Accelerator does not support ClearCase 7.1.2.9 or 8.0.0.5.  Electric Cloud recommends using ClearCase 7.1.2.10 and 8.0.0.6 or 8.0.0.7.

Cygwin

Bitness  Cygwin Version 
32-bit eMake with 32-bit  2.3.0, 2.0.4, 1.7.9, and 1.5.25 
64-bit eMake with 64-bit 2.3.0 and 2.0.4

LSF

LSF Version
Any version through external scripts 

Databases

Database
MySQL 5.5.16
MariaDB 5.5.31
Oracle 12c
Oracle 11g Release 2 
MS SQL Server 2008  

Bitnesses

Windows 
Agent
Windows 
eMake
Windows 
Cluster
Manager
Linux 
 Agent 
Linux
eMake 
Linux 
Cluster
Manager
Solaris 
Agent
Solaris 
 eMake
Solaris 
Cluster
Manager
32, 64 32, 64 32 32, 64 32, 64 32 < v9.1
64 v9.1+
64 32 32

Visual Studio

Accelerator supports Visual Studio via the Accelerator Visual Studio Integration, which comprises the Visual Studio IDE Extension, the Visual Studio Converter Extension, and the ecdevenv utility. 

  • The Visual Studio IDE Extension (installed automatically with Accelerator versions 8.0 and newer) supports the following versions of Visual Studio: 2017, 2015, 2013, 2012, 2010, 2008, and 2005. 

    Note: The Visual Studio IDE Extension for Visual Studio 2010 or later does not support Xbox builds, Windows Mobile configurations, or custom build rules.
     
  • The Visual Studio Converter Extension (installed automatically with Accelerator) supports all .NET versions of Visual Studio: 2017, 2015, 2013, 2012, 2010, 2008, and 2005.
     
  • The ecdevenv utility (installed automatically with Accelerator) supports all .NET versions of Visual Studio: 2017, 2015, 2013, 2012, 2010, 2008, and 2005.
Have more questions? Submit a request

Comments

Powered by Zendesk