KBEA-00056 - Exporting Visual Studio 6 projects

Summary

You must generate makefiles in Visual Studio 6 to gain parallelism.

Solution

One-Time Export

Consider exporting make files (.mak) for the project and building the project using the NMAKE utility. To export a makefile, select Export Makefile from the Project menu in Developer Studio. This is a one-time export, after which makefiles and Project files would potentially diverge. To avoid this, instruct Visual Studio 6 to export makefiles automatically whenever the project changes by doing the following:

  1. On the Tools menu, click Options.
  2. On the Build tab, select Export Makefile when saving the project file.

On-the-fly Export

Makefiles can be generated from .dsw files via the command-line using this technique documented on MSDN:

Export a Makefile and use NMAKE

DevStudio provides some built-in commands for automation. To see a list of these commands, select Customize under the Tools menu and choose the Keyboard tab. The commands under the respective categories are listed. These commands can be launched in the same way that add-ins and macro commands are launched. To export a makefile for all projects in a workspace, do the following from the command line:

Note: The command supplied using the -execute option is case sensitive. DevStudio should be in the path; otherwise, specify full path in the_ preceding statement._

The above will launch DevStudio, open the MyProject.dsw workspace file, and then export the makefile for all of the projects. There is a drawback in doing this---you will see the Export Makefile dialog box. The same can also be accomplished using the following VBScript macro:

See Also

Applies to

  • Product versions: All
  • OS versions: Windows
Have more questions? Submit a request

Comments

Powered by Zendesk