KBEA-00063 - Reasons Visual Studio stalls and displays a modal dialog

Summary

Visual Studio brings up a modal dialog when running against a cluster. This in turn causes the agent to eventually terminate the job as it is not making any progress.

Solution

There are a number of possible reasons, and this list is by no means complete. These are the scenarios we have seen so far:

Reason 1

Connecting/disconnecting to the console while running msdev can cause msdev to crash. This is a known bug in msdev http://support.microsoft.com/default.aspx?scid=kb;en-us;235680, and the only recommendation is to not do this.

Reason 2

Sometimes these files: *.ncb, *.opt, *.plg, *.aps, *.clw get corrupted using msdev (Visual Studio 6). This is a known issue in msdev, and the only way to solve it is to erase those files.

Reason 3

There were Electric Cloud Agents in the cluster for which devenv had never been initialized. This causes devenv to bring up a modal dialog on the console when it is started. You can use psexec -u <user> <path to devenv> to check all users on the nodes.

Reason 5

It is important that the Electric Cloud Agents are properly set up to have dedicated users. By default, each agent process on the agent hosts will run as a specific user (ECloudInternalUser1, ECloudInternalUser2 etc.). If this is not the case, the build will fail in unpredictable ways. Check what user owns the agent.exe processes on each node by looking into the Windows process list.

Reason 6

The Visual Studio 8 (and later) setting for parallel builds must be 1. The parallelism comes from multiple agents on that machine.

  1. In VS 2005, select Tools->Options.
  2. In the Option dialog, open "Projects and Solutions->Build and Run" tab.
  3. Set "maximum number of parallel project builds" to 1.

Reason 7

The Electric Cloud Visual Studio Plugin may be affected by other plugins. Remove those plugins on your host machines.

Reason 8

Another possible reason is that the plugin has a problem parsing the solution/projects. In this case, it is a good idea to set the environment variable ECADDIN_DONT_PARSE_PROJECTS. This will break the solution apart on the project level, avoiding some of the parsing issues. If that still doesn't work, disable the plugin altogether by setting ECADDIN_DONT_USE. If the build still breaks, the issue is more likely an issue with the setup of the agent machines.

Reason 9

The Visual Studio 8 (and later) 'customer experience improvement program' setting is not initialized. To initialize, run Visual Studio and click the system tray icon or select 'Help->Customer Feedback Options...'. The setting can be off or on. Perform this for all ECloudInternalUsers on all agents.

Applies to

  • Product versions: All
  • OS versions: Windows
Have more questions? Submit a request

Comments

Powered by Zendesk