KBEA-00094 - Using Cygwin 1.7.8 or later with Accelerator 5.4

Summary

You are using Cygwin 1.7.8 or later with Accelerator 5.4.

Solution

If you choose to use Cygwin version 1.7.x for x > 7, then you may need to disable or modify a workaround that ElectricAccelerator provided for a crash bug in Cygwin 1.7.7. The workaround affects only the eMake program itself, and the majority of Cygwin programs should be unaffected by the bug. The workaround is tailored to Cygwin 1.7.7 in particular; it may or may not crash future Cygwin versions.

If eMake crashes under a later Cygwin version, then disable the workaround by setting ECLOUD_CYGWIN_PATHBUF_BUG_WORKAROUND=off in the environment. If that fails, use Cygwin 1.7.7 or contact Electric Cloud Technical Support to inquire if other settings are appropriate to later Cygwin versions. Be sure to mention which Cygwin versions are acceptable, and which you prefer.

Applies to

Product versions: 5.4 and later
OS versions: Windows
Have more questions? Submit a request

Comments

Powered by Zendesk