KBEA-00115 - Visual Studio IDE Add-in fails to load

Summary

The Electric Cloud Visual Studio IDE Add-in fails to load when another add-in is installed.

Either a dialog is displayed, which indicates the add-in has thrown an exception

or the exception is caught and an error message is displayed, but the Electric Cloud menu and toolbar are incomplete:

Visual Studio contains a bug where add-ins that implement a global tools option page will fail if another add-in is installed in the ‘user application data’ area rather than the ‘all users’ application data area.

Solution

Either uninstall the other add-in, reinstall it for ‘all users’ (if available), or manually move its configuration files.

For example, a customer experienced this issue when using ‘NiftyPerforce’ add-in. NiftyPerforce stores its setup files in C:\Users\<user>\AppData\Roaming\Microsoft\MSEnvShared\Addins. It does not have an option to install for ‘all users’ and uninstalling it was not acceptable.

Moving the “.AddIn” file in the previous directory to C:\ProgramData\Microsoft\MSEnvShared\Addins (%ALLUSERSPROFILE%\Microsoft\MSEnvShared\Addins) allowed both add-ins to work.

Important notes:

1. The “.Addin” file will reference a .DLL that may have a relative or absolute path.

<Assembly>..\OtherAddIn.dll</Assembly>

You must either correct the path, or move the referenced file to allow the other add-in to continue working. In NiftyPerforce’s case, the .DLL was in the current directory, so the DLL had to be moved, too.

2. When uninstalling the other add-in, ensure that any file moves or changes are reverted before uninstalling the add-in.

3. Close Visual Studio when making any changes to the addin directories.

This Visual Studio issue can also occur with early versions of the ElectricCommander Visual Studio IDE Add-in. In this case, upgrade to v1.5 or higher.

Applies to

  • Product versions: All
  • OS versions: Windows
Have more questions? Submit a request

Comments

Powered by Zendesk