KBEA-00119 - EFS install or compile produces a GCC version mismatch warning

Summary

EFS install/compile produces this warning (with some version of GCC):

WARNING: GCC version mismatch! The version of GCC found on your PATH (4.4.3-4ubuntu5))

WARNING: is different from the version used to build the kernel (4.4.3).

WARNING: Check your PATH environment variable.

Solution

The above warning indicates that the kernel was built with a different version than what is currently your standard GCC. You may be using a custom GCC, in which case Electric Cloud recommends that you use /usr/bin/gcc. Another reason for the warning may be that you have replaced the system GCC, in which case the question is whether your Linux box can still build kernel modules.

If the compiler versions are basically identical (as in the example), chances are that you are fine. The ElectricAccelerator installer will notify you if it was actually unable to build/test the EFS or LOFS kernel module. If it does not, past experience suggests that the installation will run.

If the compile/test fails, you may be using an unsupported Linux version (please check the ElectricAccelerator Installation and Configuration Guide), or may have to put a proper GCC compiler on your system. Having a proper GCC compiler is not an ElectricAccelerator requirement, but it is a basic Linux machine configuration issue. Because of this configuration issue, your system is probably unable to build new kernel modules, which is a fundamental problem for the machine.

Applies to

  • Product versions: All
  • OS versions: Linux
Have more questions? Submit a request

Comments

Powered by Zendesk