KBEC-00284 - Using two plugin versions in parallel in Commander

 

Problem:

There are two groups that want to use two different plugin versions at the same time.

Solution:

First,  the plugins needs to be of a different major and minor version number, for example, I was able to install both of these versions:
ECSCM-Perforce-2.6.0.57360
ECSCM-Perforce-2.7.9.79502  

This was tested on a 4.2.5 system, where the 2.6.0 version is the default installed with Flow, and from the Administration, Plugins, View Catalog page download the latest version (2.7.9. at the time of this test).  

When the newer version was installed, the 2.6.0 version was still the promoted version on the plugins page. When you create a step and use the "Plugin" step type, the default version is selected (you can click on the "ECSCM-Perforce" under the Subprocedure section and see the version). 

To select the more recent version, 2.7.9, when you create the new step, use the "Subprocedure" step type, select "Plugin" as the project, and enter ECSCM-Perforce-2.7.9.79502 into the plugin name field. You can then click on "Procedure" field to see the available procedures.  

By default, when using the Plugin step type, the users will use whichever version of the plugin that is promoted. But by specifying the specific version of the plugin, users can maintain multiple versions of the plugin. {Please keep in mind that they must have different major and minor version numbers, if only the 3rd of 4th numbers are different, the plugins will overwrite one another.}

Have more questions? Submit a request

Comments

Powered by Zendesk