ElectricFlow® v6.4 FR is now available

Summary

Electric Cloud is pleased to announce the general availability of ElectricFlow 6.4 FR.  This release is of the “Feature Release” type. For more information about types of releases, please go to ElectricFlow Release Strategy

ElectricFlow 6.4 FR is a quick release that strengthens prior versions with key defect fixes and introduces error handling support for the Pipelines in the ElectricFlow Release module.

Improved control with error handling options for the Pipelines

With ElectricFlow 6.4 it is now possible to specify whether to stop or continue on error for the Pipeline Tasks and Gates. This provides flexibility to continue the Pipeline even if some of the Tasks fail or Approval Gates are rejected. This flexibility is also extended to the “Deployer” Task so that even if some Applications fail to deploy, Pipelines can continue for the other Applications. This provides more control on handling errors and also saves times as the entire Pipeline doesn’t have to be run from the beginning on failures.  

Stability improvements to strengthen prior versions 

ElectricFlow 6.4 also has key defect fixes to improve capabilities delivered in the prior versions.

Download Instructions

Download ElectricFlow 6.4 FR from Electric Cloud’s Sharefile site.

  • Login using your personalized account to the Electric Cloud Sharefile site at https://electric-cloud.sharefile.com
  • Navigate to: /products/flow/release_6.4/6.4.0.106568 or click here: 6.4.0.106568
  • Server and agent installers are located in the directory corresponding to the operating system (for example, windows)
  • IDE plug-in installers are located in the /products/commander/integrations directory
  • Release notes and product documentation are available online: ElectrircFlow Documentation

Supported Configurations

See the “System Requirements and Supported Platforms” section in the ElectricFlow Installation Guide for a complete list of supported platforms and configurations.

Upgrade

Upgrades to ElectricFlow 6.4 FR are supported from ElectricCommander 4.2.x, ElectricFlow 5.x, ElectricFlow 6.3, 6.2, 6.1, 6.0 LTS, 6.0.1 to 6.0.4. Systems that are pre-4.2 must be upgraded to ElectricCommander 4.2.x before upgrading to ElectricFlow 6.4 FR. For complete upgrade requirements and instructions, please see the ElectricFlow Installation Guide.

Support

Contact Customer Support with questions related to this release at support@electric-cloud.com

Feedback

Contact the product management team at Electric Cloud for this or any ElectricFlow releases at productmanagement@electric-cloud.com

Have more questions? Submit a request

Comments

Powered by Zendesk